注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

钱五哥の163空间

记录俺的生活和工作历程

 
 
 

日志

 
 
关于我

从事网络通信软件和开发管理开发多年,了解各类软件系统的架构、设计、开发和测试以及相应的开发方法。工作之余,喜欢研究一些自己感兴趣的事情,包括写写小程序、做做木工、看看连续剧、读读军事杂志、养鱼种花等等

网易考拉推荐

互动百科(HDwiki)和PHP版本的关系  

2013-02-21 12:41:19|  分类: IT技术 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

大云开发者社区SDN是基于互动百科的开源wiki(http://kaiyuan.hudong.com/),但是SDN开发者没有留下什么文档,在验收的时候便开始在笔记本安装(这个是php的优势),打开后页面一片空白,折腾了好久,在知道这个问题和php的版本有关系,如果采用最新的php5.4版本,则由于语法差异,hdwiki是无法正确执行的。当然SDN也就无法正确执行,如果要修改使之可以执行,则需要改动很多地方(HDWiki官方论坛有人答复,http://kaiyuan.hudong.com/bbs/viewthread.php?tid=116485&highlight=5.4),可以无法看到贴图。看到贴图需要注册账号,注册账号需要加入QQ群,真是不厌其烦。

于是干脆就降级为Php 5.3,一看还是不行,再次降到5.2,重新安装,然后就OK了。为了证明论坛的讨论,再次升级到Php5.3版本,重新安装,也OK。看来第一次降级到5.3时,必须重新安装!

折腾了大约4小时,都是晚上,真是血淋淋的教训!

?

相关信息:

  评论这张
 
阅读(109)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017